Supported Browsers

  • Internet Explorer 10 and later
  • Safari 5 and later
  • Chrome 26 and later
  • Firefox 20 and later
Download Chrome Download Firefox Download Internet Explorer Download Safari

Why do I need an up-to-date browser?

Security
Newer browsers protect you against scams, viruses, trojans, phishing and other threats.

Compatibility
yogaalliance.org uses modern website controls and features that older browsers are not capable of displaying properly.

 

"I'm not able to update my browser"

If you cannot install the latest version of Internet Explorer or Safari due to on old computer or other problems, consider installing Chrome or Firefox. Even older versions of Chrome and Firefox tend to work with all the features or this site.

If you are on a computer that is maintained by an Administrator and you cannot install a new browser, please ask your Admin to update your browser for you.

 

"I have a different issue"

For all other technical issues with using the website, please contact us.

Copyright 2014 by Yoga Alliance